Technorati रैंक वर्डप्रेस प्लगइन संस्करण 2 का विमोचन!

पहले टेक्नोराती रैंक प्लगइन की ऊँची एड़ी के जूते पर, मैंने इसे बनाने के लिए आउटपुट सामग्री को फिर से डिज़ाइन किया है सीएसएस संचालित (नीचे एक स्क्रीनशॉट है, आप मेरी साइट के साइडबार में से एक के साथ बातचीत कर सकते हैं):

Technorati रैंक वर्डप्रेस प्लगइन संस्करण 2

यह उत्पादन करने के लिए थोड़ा अधिक चुनौतीपूर्ण था लेकिन उत्पादन बहुत अच्छा है। सबसे पहले, मैंने जो सीखा है उसका उपयोग किया बिटबॉक्स इलस्ट्रेटर में छवि पर प्रत्येक आउटपुट बटन बनाने के लिए।

अगला कदम वास्तव में किसी के निर्माण के लिए शैलियों का उपयोग करना था छवि मानचित्र सिवाय इसके कि वास्तव में वहाँ है कोई नक्शा नहीं! यह बहुत अच्छा है, वास्तव में। आप समग्र div पृष्ठभूमि सेट कर सकते हैं और फिर पूर्ण स्थिति और सीएसएस का उपयोग करके प्रत्येक 'हॉटस्पॉट' बना सकते हैं। आउटपुट सीएसएस देखें।

मैंने टेक्नोराती के नए में एक लिंक भी जोड़ा है डब्ल्यूटीएफ पृष्ठ और साइट का आरएसएस पता। मुझे आशा है की आप इसे पसंद करेंगे! मुझे लगता है कि यह पहले संस्करण से बहुत बड़ा सुधार है! वहाँ एक है i नीचे दाईं ओर लिंक है जो प्लगइन को भी बढ़ावा देता है।

वर्तमान Technorati रैंक वर्डप्रेस प्लगइन संस्करण 2.0.4

23 टिप्पणियाँ

  1. 1
    • 2

      यह निश्चित है! मैं काफी समय से इलस्ट्रेटर सहायता की तलाश में था। मैं इसका उपयोग करने के लिए पर्याप्त रूप से शानदार नहीं हूं, इसलिए बिटबॉक्स जैसी साइट मुझे बहुत समय बचाती है!

  2. 3

    मैंने "पत्र" to के लिए आपके निर्देशों का पालन करते हुए सबसे नया और सबसे बड़ा स्थापित करने की कोशिश की

    लेकिन मुझे निम्नलिखित त्रुटि मिली

    घातक त्रुटि: गैर-मौजूद वर्ग को तत्काल नहीं बता सकता: लाइन 4 पर /home/winex64/public_html/wp-content/plugins/technorati-rank/technorati-rank.php में simplexmlelement

    कोई सुझाव?

    • 4
      • 5

        यह मुझे पहले जाँच करना सिखाएगा .. जाहिर है कि Lunarpages PHP का 4.4.4 चल रहा है

        मुझे लगता है कि मैं दूसरे संस्करण की जाँच करें या कठिन लटका और अगर वे 5.0 करने के लिए उन्नयन देखना होगा

        • 6

          मुझे आशा है कि वे करते हैं! लेकिन मुझे आपके होस्ट अपग्रेड की भी उम्मीद है। PHP5 वास्तव में कुछ बेहतर प्रदर्शन सुधार लाता है, साथ ही एपीआई का उपभोग करने के लिए कुछ बेहतर उपकरण भी है। मैं जंपलाइन का उपयोग करता हूं, आपको मेरे होम पेज पर मेरी प्रायोजक सूची में एक लिंक दिखाई देगा। मेरा यह भी मानना ​​है कि Dotster के पास नवीनतम और महानतम के साथ कुछ अच्छे VDS होस्टिंग हैं।

      • 7

        डौग,
        मुझे भी यही तकलीफ़ है
        मैंने अपने होस्ट को फोन किया और उन्होंने कहा कि मेरे सर्वर में PHP 4 और PHP 5 हैं, लेकिन अगर मैं PHP 5 का उपयोग करके एक फ़ाइल चलाना चाहता हूं, तो स्क्रिप्ट को .php5 फ़ाइल एक्सटेंशन रखना होगा।

        तो ... मैंने फ़ाइल एक्सटेंशन को बदल दिया है, और यह वर्डप्रेस में प्लगइन्स से गायब हो जाता है।

        कोई विचार?

        • 8

          वाह - मुझे यकीन नहीं है, बिटकॉइन। आइए एक नज़र डालते हैं कि सैमथॉन ने पहले संस्करण को PHP4 में बदलने के लिए क्या किया था।

          मैं वास्तव में आश्चर्यचकित हूं कि वहां कितने मेजबान हैं जो नवीनतम और महान नहीं हैं!

  3. 10

    बहुत बढ़िया प्लगइन, उत्कृष्ट स्टाइल! धन्यवाद डौग, और महान काम। मैं पहले वाले के बारे में भी कभी नहीं जानता था, लेकिन यह मेरे साइडबार सर्वनाम में जा रहा है।

    यह वास्तव में देखने के लिए है कि मेरे इलस्ट्रेटर युक्तियों ने आपको अपने बटन बनाने में मदद की !!!!!

    एक बार फिर धन्यवाद,

    ~ BittBox

    • 11

      धन्यवाद, बिटबॉक्स! मुझे लगता है कि मुझे शैली के लिए एक अच्छी आंख मिल गई है, लेकिन मुझे लगता है कि यह ज्यादातर समय सही नहीं है। वास्तव में अपने नमूनों को डाउनलोड करने और उन्हें अलग करने में सक्षम होने के नाते जो अंतर करता है। मैं वास्तव में उन विचारों पर अमल करने में सक्षम हूं। 🙂

      मैं अपने ब्लॉग के हेडर और बैकग्राउंड पर कुछ विचारों के साथ कर रहा हूँ।

  4. 12

    ठीक है, डौग, ऐसा लगता है कि संस्करण 2 प्लगइन मुझसे नफरत करता है। मुझे त्रुटि संदेश मिले:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    त्रुटि संदेशों के बावजूद, यह मेरी Technorati रैंक (~ 26.5k: D) को भी दिखाता है। मैं PHP के बारे में जानने के लिए पर्याप्त नहीं हूं कि यह जानने के लिए कि यह एक फाइल पर क्यों रो रहा है।
    दिलचस्प रूप से पर्याप्त है, हमारे सर्वर पर, हम SuPHP का उपयोग करते हैं, इसलिए सब कुछ हमारे रूप में चलता है (इसलिए chmod आवश्यकताओं को अब विश्व-लेखन योग्य फ़ाइलों की आवश्यकता नहीं है, और उदाहरण के लिए chmod'ed बहुत अधिक होने पर php स्क्रिप्ट निष्पादित नहीं होगी)।

    इस सबडोमेन के लिए सभी php php5 के रूप में चलते हैं।

    कोई विचार?

    • 13

      क्या आपके पास wp-content / cache directory Xial है? मुझे लगा कि WP-Cache के समान कैश डायरेक्टरी का उपयोग करना अच्छा होगा। अड़चन में, शायद यह एक अच्छा विचार नहीं था! वह लाइन निश्चित रूप से कैश फ़ाइल में लिखना है।

      • 14

        मैं निश्चित रूप से, डौग। मैं काफी समय से WP-Cache चला रहा हूं। 🙂

        मैं थोड़ा उत्सुक था, इसलिए भी कि मैं इस बारे में शिकायत क्यों करूं, क्योंकि मेरे पास आवश्यक निर्देशिका है, लेकिन मुझे लगता है कि यह पूरी तरह से कुछ और है।

      • 15

        जोड़ने के लिए जानकारी का दिलचस्प सा:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        यह अभी भी त्रुटियों को लौटाता है।

    • 16

      बस उसी त्रुटि के साथ झंकार करना चाहते हैं। साइट php5 चलाता है, और बटन प्रदर्शित करता है।
      मैंने 121-123 लाइनों की टिप्पणी करने की कोशिश की, और प्लग ठीक काम करता है। क्या मैं इसे लाइव कर सकता हूं, या उन लाइनों की कमी लंबे समय तक परेशानी का कारण बन सकती है?

  5. 17

    मुझे ऊपर जैसी त्रुटियां मिल रही हैं, मुझे भी लगा कि यह मेरा कैश डीआईआर है लेकिन मेरे पास एक है और यह भी सुनिश्चित करें कि राइट राइट सही थे।
    साइड बार में यह प्लगइन (रैंक के साथ) दिखाएगा लेकिन इसके ऊपर की त्रुटियों के साथ।

    • 18

      हाय रिचर्ड,

      क्या आप देख सकते हैं कि आपके पास PHP संस्करण 5+ है और CURL सक्षम है? आप अपनी साइट पर एक पेज बनाकर ऐसा कर सकते हैं <?php phpinfo(); ?> एक पृष्ठ में फिर उस पेज को ओपन करें। पृष्ठ के शीर्ष पर आपके PHP का संस्करण होगा और आप इसे सक्षम करने के लिए CURL की खोज कर सकते हैं।

      धन्यवाद!
      डॉग

      • 19

        खैर, डौग, मैंने अपने PHP संस्करण को डबल-चेक किया।
        मैं PHP5 चला रहा हूँ, और cURL (PHP में संकलित की जाने वाली चीजों के लिए, मेरे होस्ट के लिए मेरे सामान्य तीन अनुरोधों में से एक) में संकलित किया गया है।

        बाकी सब ठीक काम करता है, लेकिन मुझे पूरी तरह से यकीन नहीं है कि यह प्लगइन क्यों चोक है, जब तक कि यह PHP में संकलित संस्करण का संस्करण नहीं है (हम 7.15.4 पर हैं, और नवीनतम 7.16.1 प्रतीत होता है)। हालाँकि, मैं php5 को फिर से संकलित करने के लिए अपने मेजबान को रोकना नहीं चाहता, अगर मैं इसे मदद कर सकता हूं। <: 3

        • 20

          मैं इस सप्ताह के अंत में एक गहरा रूप लेने जा रहा हूं। यह कुछ साइटों पर किसी भी समस्या के बिना चल रहा है - इसलिए यह 3 चीजों में से एक है: 1. कैश, 2.URL या 3. PHP संस्करण।

          मैं XML को खींचने और पार्स करने के लिए पुराने PHP 4 कार्यक्षमता का उपयोग कर सकता हूं लेकिन यह इसे थोड़ा धीमा कर सकता है - मैं इस सप्ताहांत का परीक्षण करने जा रहा हूं। मैं सभी इनपुट की सराहना करता हूं। "हॉस्टन हमारे पास समस्या हे!"।

  6. 21

    बस एक नोट: टेक्नोराती ने लॉन्च किया है अधिकार प्लगइन।

    इसके अलावा - उन सभी के लिए जो इस प्लगइन के साथ समस्या कर रहे हैं, मैं वास्तव में आपको एक नए होस्ट में जाने के लिए प्रोत्साहित करूंगा :)। मैंने अपने होस्ट के साथ अपने तल पर एक 12 महीने का मुफ्त विशेष प्राप्त किया है हमारे बारे में इस पृष्ठ पर ज़ूम कई वीडियो ट्यूटोरियल और अन्य साहायक साधन प्रदान करता है।

  7. 22
  8. 23

    मुझे काफी अनुरोध मिले हैं कि कैश फ़ाइल से लिखने या पढ़ने में त्रुटियां हुई हैं। मैंने वास्तव में एक मुद्दे की पहचान की, जहां मैं कैश फ़ाइल को रूट निर्देशिका में धकेल रहा था और खींच रहा था। मैंने संस्करण 2.0.4 को संशोधित किया है ताकि यह प्लगइन की निर्देशिका के भीतर कैश उपनिर्देशिका को लिख दे।

    कृपया मुझे बताएं कि यह कैसे चलता है! (अभी भी SimpleXML और cURL की जरूरत है!)

तुम्हें क्या लगता है?

यह साइट स्पैम को कम करने के लिए अकिस्मेट का उपयोग करती है। जानें कि आपका डेटा कैसे संसाधित किया जाता है.